Technical Requirements

In order to ensure that Evli's online services (evli.com and My Evli) work properly, please take note of the following technical requirements.

Evli.com and My Evli runs most reliably with the most recent versions of Chrome, Safari, Firefox and Edge. On mobile devices, the services function most reliably with the latest phone and tablet versions of Chrome and Safari. We do not recommend using the service with Internet Explorer.
JavaScript needs to be enabled in your browser when using My Evli. JavaScript is automatically enabled if you haven't disabled it in your web browser.

Evli uses long-term persistent cookies for collecting visitor statistics, and temporary session cookies for session management.